Monday, June 13, 2016

Freebsd


 Have you encountered error like this when install kde on FreeBSD?

sysctl: unknown oid 'compat.linux.osrelease'

linuxulator is not (kld)loaded, exiting


 If it's so, then just do like this

#kldload linux


But it tell that no linux module on the system. Well, just install it

cd /usr/src/sys/modules/linux

make install clean


Ehm, there's more error

compat.linux.osrelease: 2.6.16 is not supported freebsd


apparently we have to edit the .conf manually


# printf "compat.linux.osrelease=2.6.18\n" >> /etc/sysctl.conf

# sysctl compat.linux.osrelease=2.6.18

# pkg install emulators/linux_base-c6


OK, back to kde install sequence, :)

# pkg install xorg

# pkg install nvidia-driver

# pkg install virtuoso

# pkg install kde

# pkg install gtk-oxygen-engine

# pkg install kde-gtk-config


Add to /boot/loader.conf:

linux_load="YES"

nvidia_load="YES"

Add to /etc/rc.conf:

dbus_enable="YES"

hald_enable="YES"

kdm4_enable="YES"


Load new kernel modules:

# kldload linux

# kldload nvidia


Create ~/.xinitrc for KDE (just this single line here):

exec /usr/local/kde4/bin/startkde


And we are good to go, :)